|
안녕하세요.
피벗테이블 원본에서 데이터가 수정되었다면
피벗테이블이 만들어진 시트에서 [옵션] 탭의 [데이터] 그룹에서 [새로고침]을 클릭하시면
됩니다.
이 과정을 매크로로 기록하여 매크로 실행 단추를 하나 만들어 두면 좀 더 편리하게
이용하실 수 있습니다. 알려주신 매크로 코드는 바로 이 과정을 기록한 것입니다.
그 순서는 다음과 같습니다.
1. [개발 도구] 탭에서 [매크로 기록]을 클릭합니다. [개발 도구] 탭이 표시되지 않았다면
[Excel 옵션]에서 '리본 메뉴에 개발 도구 탭 표시..]를 선택하시면 됩니다.
2. 피벗 테이블이 작성된 시트를 선택한 후 [옵션] 탭의 [새로 고침]을 클릭합니다.
3. [Alt] + [F11] 키를 눌러보면 매크로가 기록된 코드를 보실 수 있습니다.
4. [개발 도구] 탭의 [컨트롤] 그룹에서 [삽입]-[단추]를 삽입하고 기록한 매크로를 지정합니다.
5. 단추 이름을 '원본 반영'으로 수정합니다. 물론 원하시는 이름으로 지정할 수 있습니다.
이제 원본이 수정된 후 이 단추를 클릭하시면 원본이 반영될 것입니다.
파일을 첨부해 드립니다.
매크로 기록이나 매크로가 포함된 문서를 여는 방법 등은 [엑셀강좌]-[매크로/VBA] 강좌를 참고하세요.
|